Thursday, November 4, 2010

Bug Hunt!

Need your help guys for fixing an extremely annoying crash bug.

THE BUG
You either always have the bug and can't start the game, or you don't.
The game crash soon after starting.
The game log looks like this:
0 init main : starting program...
1 init main : date : xxxxxxx
2 init main : game version : alpha 4.2.
3 init main : creating main form...
THE HUNT
 If you have this bug, please follow these steps.
  1. Download ASoft .NET Detector X here: http://www.asoft.be/prod_netver.html
  2. Extract somewhere and run it, it tells you what .NET versions you have installed.
  3. Copy all the text in the textbox and post it there + your OS version (eg: Win7 64 bits).
  4. Feel warm and fuzzy inside for helping fixing a bug.
End of post.

5 comments:

  1. AARON!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!November 4, 2010 at 8:32 PM

    Yay, a blog post!

    ReplyDelete
  2. We were waiting fo you, I was afraid you stopped the development of this awesome game!

    I will try to help and look into it tomorrow.

    ReplyDelete
  3. I personally haven't had any *serious* crashes happen to me since Alpha 4.2 was released.

    Any idea of where you first heard about the bug? May help in figuring out how to reproduce it so that others can get on it!

    ReplyDelete
  4. From the reports I got it looks like you either have the bug -and so can't run the game at all- or you don't. Should have made that clear in the post.
    This is an annoying bug to track and fix because people who have it are unlikely to report it and just dump the game in a trash can, since the game doesn't work at all.

    ReplyDelete